[xmonad] xmonad always requires reloading after reboot...

Tim Wilkinson mu31tw at yahoo.co.uk
Sun Sep 4 14:34:02 CEST 2011

Hello everyone,

I've been using xmonad for around 6 months, both at work and at home, and I think it's pretty much the best thing since the proverbial sliced bread.  I'm just having one small problem that I wanted to ask for some advice on:  I use xmonad with xfce4, mainly  for the toolbar and also for a few additional plugins, and the extremely-useful mod-p launcher.  Recently I've changed the mod key in ~/.xmonad/xmonad.hs to mod4 (the windows key) because using alt was clashing with some other programmes, but this unfortunately stopped my beloved mod-p from functioning, (using either the old alt-p or the expected new mod4-p).  I wanted this function mapped to mod4-p, so I tried remapping this key combination in xmonad.hs to spawn the correct process when I hit mod4-p, and this works fine, -except- that it only works after reloading xmonad.hs (mod4-q) after every startup.  The mod4 key works perfectly except for this, and after reloading xmonad mod4-p works
 exactly as expected, so I was just wondering if anyone has any idea why it needs reloading each time?  I've tried looking around the appropriate xmonad pages, and have so far not found any solutions, so thought I'd ask around a bit further.  My full xmonad.hs is shown below, it's pretty short and sweet.

Thanks very much!

Tim W.


import XMonad
import XMonad.Config.Xfce
import XMonad.Util.EZConfig

main = xmonad $ xfceConfig
        { borderWidth = 3
        , focusedBorderColor = "#00688B"
        , modMask = mod4Mask    -- Use win key instead of Alt
        [ ((mod4Mask, xK_p), spawn "xfrun4")
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/xmonad/attachments/20110904/f82d6030/attachment.htm>

More information about the xmonad mailing list