[xmonad] Cabal install problem

Brandon Allbery allbery.b at gmail.com
Mon Aug 29 23:33:29 CEST 2011

2011/8/29 Tayfur Yilmaz <yilmaz.tayfur at gmail.com>

> Hi everyone
> I have some problem for install 'cabal-install package'  I downloaded and
> succesfully build a binary source ghc-7.0.2. Then I want to install
> cabal-0.10.2 and ı see some warning and last output like this
> Linking Setup ...
> Configuring Cabal-
> Setup: At least the following dependencies are missing:
> base >=4 && <3 && >=2 && <5, unix >=2.0 && <2.5

For what it's worth, I got this while manually bootstrapping
haskell-platform onto a GHC HEAD build and it turned out to be a complex
interaction between unix, network, bytestring, and base versions.  Cabal's
ability to report such things is limited, to say the least.  (More
specifically:  I'd have to go through the bootstrap again to get the full
details, but Cabal somehow managed to conclude that it needed a version of
base with bytestring in it at the same time that it needed a modern version
of base, and this was triggered somehow by newer versions of network which
have subsumed the old network-bytestring package.  IIRC it actually made a
certain twisted sense at the time.)

brandon s allbery                                      allbery.b at gmail.com
wandering unix systems administrator (available)     (412) 475-9364 vm/sms
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/xmonad/attachments/20110829/843ab78a/attachment.htm>

More information about the xmonad mailing list