[xmonad] cannot build xmonad-contriib from darcs

Adam Vogt vogt.adam at gmail.com
Sat Sep 25 15:51:31 EDT 2010

* On Friday, September 24 2010, Ivan Lazar Miljenovic wrote:

>On 24 September 2010 00:48, Sergey Manucharian <ingeniware at gmail.com> wrote:
>> Hi folks,
>> I'm not a haskell programmer but I succesfully built xmonaf-contrib
>> from darcs many times. Today it does not work:
>> ------------------------------8<-------------------------------
>> Configuring xmonad-contrib-0.9.1...
>> Preprocessing library xmonad-contrib-0.9.1...
>> Building xmonad-contrib-0.9.1...
>> [ 85 of 208] Compiling XMonad.Util.Image ( XMonad/Util/Image.hs,
>> dist/build/XMonad/Util/Image.o )
>> XMonad/Util/Image.hs:24:39:
>>    Module `XMonad.Util.Font' does not export `fi'
>> ------------------------------8<-------------------------------
>Having just looked at the repo, XMonad.Util.Font does indeed export
>fi: http://code.haskell.org/XMonadContrib/XMonad/Util/Font.hs
>I'm guessing you pulled in the middle of some patch pushes.  Try
>pulling and building again, possibly doing a "cabal clean" (or
>"runhaskell Setup.lhs clean") before building.

Somebody else brought up the same error in #xmonad, which was fixed by
cleaning the repo first.

Evidently ghc (or cabal) can't figure out that some files need to be
recompiled when imports are rearranged. But I couldn't come up with a
small test case, or even reproduce it by asking darcs to remove and then
apply the (most likely) problematic patch:

   Mon Sep 13 19:38:50 EDT 2010  Adam Vogt
    * Remove last excess definition of `fi' (fromIntegral)

Perhaps the difference in timestamps isn't the same.


More information about the xmonad mailing list