[xmonad] Re: Issue 363 in xmonad: non-positive argument error on NVidia Xinerama set

codesite-noreply at google.com codesite-noreply at google.com
Fri Jan 22 14:18:32 EST 2010

Comment #1 on issue 363 by seanerussell: non-positive argument error on  
NVidia Xinerama set

Nice.  Accidental carriage return caused this to be submitted.

Anyhoo, I have an NVidia dual monitor graphics card set up to serve up two  
via Xinerama.  Initially, xmonad worked on this setup, but didn't recognize  
second monitor; eventually, I found out that the Haskell X11 library hadn't  
compiled with Xinerama, so I fixed that.  Now, xmonad exits as soon as it  
is started
with an error that:

   xmonad-i386-linux: xmonad: StackSet: non-positive argument to StackSet.new

I stripped my xmonad.hs down to the bare minimum (so that it didn't  
StackSet at all), and the error was still reported.

In fact, I'm not sure that this has anything to do with Xinerama, now,  
because I've
just tried to run xmonad on an Xnest session, and got the same error.

I'm sure that this is a local problem, but I'm not sure how to proceed in  
this.  Any suggestions?

xmonad: 0.9.1
GHC: 6.10.4
xorg: 7.3
ubuntu: Ubuntu 8.04.3 LTS

All Haskell dependencies have been built out of cabal, refreshed as of  

'xmonad --recompile' produces no STDERR/STDOUT output, and exits with exit  
code 0.

	xmonad.hs  4.2 KB

You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:

More information about the xmonad mailing list