[xmonad] The minimal xmonad.hs has error

Adam Vogt vogt.adam at gmail.com
Sun Jan 10 11:07:36 EST 2010

* On Sunday, January 10 2010, Ivan Miljenovic wrote:

>2010/1/10 Yuliang Wang <jadelightking at gmail.com>:
>> xmonad.hs:1:7:
>>     Could not find module `XMonad':
>>       it is a member of the hidden package `xmonad-0.9'
>>       Use -v to see a list of the files searched for.
>What does "ghc-pkg check" say?

xmonad-0.9 shouldn't be a hidden package... something must be wrong
with your xmonad installation.

If the only problem is that xmonad-0.9 is hidden, you can correct this

$ ghc-pkg expose xmonad-0.9

But "ghc-pkg check" might have more to say. Also "ghc-pkg list"


More information about the xmonad mailing list