[xmonad] Upgrading repo formats

adam vogt vogt.adam at gmail.com
Fri Apr 23 15:43:06 EDT 2010

sorry for the duplicate gwern, I forgot to CC the list:

On Sat, Apr 10, 2010 at 1:16 PM, Gwern Branwen <gwern0 at gmail.com> wrote:
> While waiting on a slow connection today to darcs get XMC, I had time
> to ponder. The patches are (or would be) in my global cache, so it
> could go much faster. Why doesn't it? Because xmonad-contrib and
> xmonad-core are both still using darcs-1 fomatted repositories.
> Is there any particular reason to not upgrade? Even Debian Stable has
> Darcs 2.x (http://packages.debian.org/lenny/darcs), so it's not as if
> there are many people who would be unable to do a darcs get.
> --
> gwern

I support this.

Since this isn't something we can easily rollback, (without the messy
situation of keeping the unupgraded repository updated in parallel), it
is important to have some consensus before updating repo formats.


More information about the xmonad mailing list