[xmonad] XMonad.Actions.Volume

Brent Yorgey byorgey at seas.upenn.edu
Thu Jun 18 19:05:43 EDT 2009

On Thu, Jun 18, 2009 at 08:30:20AM -0400, wagnerdm at seas.upenn.edu wrote:
> This is probably something of a controversial patch: it adds two 
> dependencies.  I don't think the "parsec" dependency is a big deal, since 
> that comes with GHC, and we can therefore expect most users to have it 
> already. The other dependency is the "split" package.  Let me know if you 
> want me to just pull in the definition of the particular splitting function 
> I'm using.
> +    build-depends:      mtl, unix, X11>=1.4.3, xmonad>=0.8, xmonad<0.9, utf8-string, parsec, split

Hmm.  I'm not sure how I feel about the extra
dependencies. (Literally---I'm not using "I'm not sure how I feel" as
a euphemism for "I don't like it").  But I thought I should point out
at the very least that writing 'parsec' with no version constraints is
just asking for trouble--versions 2 and 3 (which both occur in the
wild) aren't quite compatible. I don't imagine the API of split
changing much, but just to be safe it's probably a good idea to put
version constraints on that too, something like split >= 0.1.1 && <
0.2.  It's just good practice to put version constraints on things--in
fact, word has it that at some point in the not-too-distant future
Hackage will stop accepting packages that don't specify upper bounds
on their dependencies.  see



More information about the xmonad mailing list