[xmonad] Re: Support for OpenSolaris?

Euan Harris euan.harris at gmail.com
Sat Jan 31 18:38:00 EST 2009


I've been using Xmonad 0.7 on my OpenSolaris 2008.11 machine for a
couple of weeks.  I built it using the GHC 6.8.1 tarball from
haskell.org, which needed a few extra packages from the OpenSolaris
'pending' repository.   Here's the recipe that worked for me:

1. Add the OpenSolaris pending repository to the package manager: (as
root) pkg set-authority -O http://pkg.opensolaris.org/pending
opensolaris-pending (or use the GUI tool)

2. Install some packages that GHC and the Haskell X11 library will
need: (as root) pkg install gmp readline5 SUNWncurses SUNWxorg-headers
(or use the GUI)

3. Install ghc-6.8.3 from the tarball here:

4. export LD_LIBRARY_PATH=/usr/gnu/lib:$LD_LIBRARY_PATH

5. Build and install the X11 package from Hackage:

6. Build and install xmonad-0.7 and xmonad-extras-0.7
and http://hackage.haskell.org/cgi-bin/hackage-scripts/package/xmonad-contrib-0.7).
You may find it more convenient to compile the Setup.hs file (ghc
--make Setup; ./Setup build...) than to use runhaskell.   If you have
trouble at the install step and you have su'ed to root, check that
LD_LIBRARY_PATH is still set in the root shell.

7. Edit ~/.Xclients to include at least the following lines:
export PATH=/usr/local/bin:$PATH
export LD_LIBRARY_PATH=/usr/gnu/lib:$LD_LIBRARY_PATH

8. Log out.  At the GDM login window, click the 'Option' button,
choose '2. Run Xclient script', click 'Change session' and then log

9. If all your windows have tags like [English/European] at the
bottom, edit your /etc/default/init file and change the
LANG=<whatever> line to read LANG=C.   You need to reboot to for this
change to take effect.

If Xmonad doesn't start when you log back in, you can get back to
Gnome by killing X (press Ctrl-Alt-Backspace) and choosing Gnome in
the Option menu on the GDM login window.

I tried to install the GHC 6.10 tarball from haskell.org, but it has
some prerequisites that are not available in the OpenSolaris
repositories.   I haven't tried Xmonad 0.8.1 yet.  Also, note that
software from the OpenSolaris pending repository is untested and not
supported - so far I haven't had any trouble but you should take care.

I've used this recipe on two different machines, so with a bit of luck
it's got all the necessary steps!

Good luck!

More information about the xmonad mailing list