[xmonad] Xmonad-contrib build failure

aditya siram aditya.siram at gmail.com
Sun Jan 4 17:39:39 EST 2009

Hi all,
I am building XMonad-Contrib using cabal-install and I get the following
    The section `5 `seconds`' takes one argument,
    but its type `Int' has none
    In the `duration' field of a record
    In the expression:
        DzenUrgencyHook {duration = (5 `seconds`), args = []}
    In the definition of `dzenUrgencyHook':
        dzenUrgencyHook = DzenUrgencyHook
                            {duration = (5 `seconds`), args = []}
cabal: Error: some packages failed to install:
xmonad-contrib-0.8 failed during the building phase. The exception was:
exit: ExitFailure 1

Cabal version is:
>cabal-install version 0.6.1
>using version of the Cabal library
And xmonad versions are:
 * xmonad
      Latest version available: 0.8
      Latest version installed: 0.8
      Category: System
      Synopsis: A lightweight X11 window manager.
      License:  BSD3

 * xmonad-contrib
      Latest version available: 0.8
      Homepage: http://xmonad.org/
      Category: System
      Synopsis: Third party extensions for xmonad
      License:  BSD3

Thanks for your help ..,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/xmonad/attachments/20090104/533106d1/attachment.htm

More information about the xmonad mailing list