[xmonad] another patch: modifies selection
loupgaroublond at gmail.com
Fri Jan 2 10:40:00 EST 2009
2009/1/1 Brent Yorgey <byorgey at seas.upenn.edu>:
> On Sun, Dec 21, 2008 at 09:25:23PM -0500, Yaakov Nemoy wrote:
>> Hey List,
>> Here's another patch. It modifies the XSelection module so you can
>> pass a string modifying function to the promptSelect functions. This
>> lets you run your own escape routines for various reasons.
> These functions seem useful. However, would you mind giving them
> better names, adding some Haddock documentation, and resubmitting the
> patch? Also, why is the unsafe variant necessary?
I'm not sure what to call them other than those names. The unsafe
variant is necessary because there is an unsafe variant of the
original function. That said, the word 'unsafe' can be dropped from
the function name. If you have any better names, just fill them in
here, and i'll include them with my revised patch.
> xmonad mailing list
> xmonad at haskell.org
More information about the xmonad