[xmonad] Re: xmonad darcs, haddock, ghc and Ubuntu Intrepid

mail at justinbogner.com mail at justinbogner.com
Tue Feb 24 23:46:07 EST 2009

Kathryn Andersen <kat_lists at katspace.org>
> I'm running Ubuntu Intrepid (8.10) and I'd like to switch from the
> default xmonad (0.8) to the xmonad in darcs.  The ghc version is 6.8.2,
> which I gather is okay, but the haddock version is the ancient 0.8
> version, which is not.  However, if I try to remove haddock (in order to
> replace it with a newer version) apt then removes ghc as well!
> Any tips as to how to get around this?
> Kathryn Andersen

You can simply install the new haddock without removing the old one, it
works fine. However, the best approach is to build cabal-install [1] and
use that to manage newer haskell libraries than are in ubuntu.

[1]: http://hackage.haskell.org/cgi-bin/hackage-scripts/package/cabal-install

More information about the xmonad mailing list