[xmonad] Re: New layout Patch (Cross)

Luis Cabellos zhen.sydow at gmail.com
Thu Feb 12 13:51:53 EST 2009

I updated to Haddock 2.4.1 (from hackage, configure, build & install).
But I getting something strange. If I remove all the comments on the
file i getting the error:

haddock: internal Haddock or GHC error: No libdir found

But with comments, I also getting the :
XMonad/Layout/Cross.hs:53:4: parse error on input `!'
haddock: Failed to check module: XMonad.Layout.Cross

And If I remove the comments on line 53 data I also get:

haddock: internal Haddock or GHC error: No libdir found

I don't know where the problem is. anything has the same problem before?

On Wed, Feb 11, 2009 at 6:05 PM,  <mail at justinbogner.com> wrote:
> Luis Cabellos <zhen.sydow at gmail.com>
> writes:
>> I remove test because I suposse my haddock has a bad configuration.
>> I remove comments on the error line and the error is related to another
>> different version:
>> dist/build/tmp/./XMonad/Layout/HintedTile.hs:"dist/build/tmp/./XMonad/Layout/
>> HintedTile.hs": 56:5: parse error in doc string: [haddock: Internal Happy error
>> I have versions:
>> $ haddock --version
>> Haddock version 0.8, (c) Simon Marlow 2006
>> $ ghc --version
>> The Glorious Glasgow Haskell Compilation System, version 6.8.2
>> Someone has any idea was the problem is?
> Your haddock version is too old. It should work if you upgrade to 2.4.1,
> which is the newest released version.
> _______________________________________________
> xmonad mailing list
> xmonad at haskell.org
> http://www.haskell.org/mailman/listinfo/xmonad


LC, ("Solo porque seas un paranoico no significa que no te persigan."
- Kurt Cobain)

More information about the xmonad mailing list