[xmonad] OO.o won't open, Dialogs and GIMP won't float/tile right

Dayo Adewunmi contactdayo at gmail.com
Tue Apr 28 14:25:19 EDT 2009

Hi Wolff,

thanks for your reply. Oddly enough I have no problem starting 00o, anymore.
Don't ask me why, though. I just gave it a shot again the other day, and 
there it was.
One thing I noticed - and this might be why 00o wouldn't start - I had 
one particular
workspace with only Firefox in it, and I wasn't able to open anything 
else. Not even
a simple shell. At least that's what I thought until I happened to look 
at the xmobar,
and saw that the shell had indeed started. I could see the title in the 
xmobar bar, but
I couldn't see the actual shell. Cycling through the various layouts 
didn't help.

Rebooting got rid of that, though. I also tried launching nautilus, to 
browse through
files, but all it did was launch the desktop, i.e. the wallpaper (which 
is usually not there),
and the desktop icons. In the nautilus workspace, I wasn't able to 
launch anything else.
Again, rebooting sorted that out. Haven't tried starting Nautilus since 
then. Is there
a proper way for me to browse files with the GUI, as opposed to browsing 
in the shell?

Gimp still won't float right, so I dedicate it to its own workspace. 
That's not really something
that bothers me. What bothers me a lot is the buttons in dialog windows 
often are below
the edge of the screen :-(

I'm going to hang out on IRC more too, and see if they can help me there.


Wirt Wolff wrote:
> Sorry for the long wait for a reply, Dayo.
> Excerpts from Dayo Adewunmi's message of Wed Apr 22 09:49:07 -0600 2009:
>> Hi guys.
>> I love Xmonad. Installed it on my Ubuntu 8.10 laptop a couple of days 
>> ago for the first time, so I'm still a newbie. I managed to add Xmobar, 
>> by following the installation instructions from here: 
>> http://code.haskell.org/~arossato/xmobar/#installation and using the 
>> config example from here: 
>> http://haskell.org/haskellwiki/Xmonad/Config_archive/John_Goerzen's_Configuratio
>> n#Configuring_xmonad_to_use_xmobar
>> My modifier is Alt, so I press Alt+p to start apps from the grey menu 
>> bar that appears at the top of the screen, and so far the only one that 
>> won't start is OpenOffice3.
> I don't use dmenu, so ymmv, but hopefully the ff. would work for you
> too, in case you don't happen to be selecting the intended oo___ app
> from dmenu: in shell at least 'oowriter' starts document editor and
> 'ooffice' the generic oo gateway. (I use XMonad.Util.Scratchpad or a
> shell to start apps, so can just type 'oo<tab>' to see the available
> openoffice commands to choose from.)
>> Also, I have to start GIMP 2.6 in a dedicated workspace, because it just 
>> won't tile correctly with other open apps. Dialog prompts like "SaveAs"
>> and "Open" of various apps don't float right either, leaving the "Save",
>> "Open", "Cancel" buttons hanging out of sight below the visible line
>> of the screen.
> Hmm, with the xmonad.hs you attached I'd expect all Gimp things to
> float, and dialogs to be in the upper left corner. Maybe your Gimp has
> different X properties than the expected class name of "Gimp". This link
> [1] has a bunch of info about xprop, hooks, and Gimp,
> #xmonad  on irc.freenode.net is another place to get help with the
> dialog window locations.
>> Also pressing Alt+Enter is said to switch the active frame with the 
>> frame in the Master pane, but this stopped working after some editing of 
>> xmonad.hs (or .xmobarrc?). Unfortunately, I can't remember what changes 
>> I made that caused Alt+Enter to stop working.
> The xmonad.hs you pasted should use the default keys, including Alt-Enter,
> so maybe try #xmonad for help troubleshooting what's going wrong.
> (.xmobarrc only affects xmobar, so long as it's working and displaying
> workspaces xmonad is writing to it -- nothing to do with Alt-Enter)
> Welcome, hope you continue to like xmonad and customizing it to your
> needs.
> [1] http://haskell.org/haskellwiki/Xmonad/General_xmonad.hs_config_tips#Gimp
>> Here are my specs and configs:
>> ~/.xmonad/xmonad.hs: http://pastebin.com/f5e107f70
>> ~/.xmobarrc: http://pastebin.com/febe32b4
>> Ubuntu 8.10 Intrepid Ibex
>> Linux 2.6.27-11-generic #1 SMP Wed Apr 1 20:57:48 UTC 2009 i686 GNU/Linux
>> Regards
>> Dayo

More information about the xmonad mailing list