[xmonad] Issue 289 in xmonad: withWindowNavigation plays badly with Gnome config

codesite-noreply at google.com codesite-noreply at google.com
Sat Apr 18 14:33:09 EDT 2009

Status: New
Owner: ----

New issue 289 by stefano.zacchiroli: withWindowNavigation plays badly with  
Gnome config

What steps will reproduce the problem?
1. use xmonad-contrib
2. use Gnome config and XMonad.Actions.WindowNavigation

What is the expected output? What do you see instead?

Moving to left/right window works, as well as switching with them.
Moving up/down does not work. Switching up/down works but brings down the
Gnome panel :-( After that, moving up/down starts working.

I found a description of this exact problem in a post to the xmonad mailing
list (even though in an unrelated thread):
http://markmail.org/message/itxw6v2jn6lpfcs4  No answer though.

Additionally, I'm also using the Nautilus desktop, and it seems that by
enabling WindowNavigation, the "magic" which makes the desktop behave as
expected (i.e., staying on the background of all workspaces) vanish. I see
the Nautilus desktop only on the first workspace.

What version of the product are you using? On what operating system?

Debian GNU/Linux. xmonad 0.8.1, xmonad-contrib 0.8.1.

Are you using an xmonad.hs?  Please attach it and the output of "xmonad

xmonad.hs attached, no output for "xmonad --recompile".

Please provide any additional information below.

	xmonad.hs  1.9 KB

You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:

More information about the xmonad mailing list