[xmonad] Issue 235 in xmonad: Install problem finding X11 libs on OSX Leopard

codesite-noreply at google.com codesite-noreply at google.com
Wed Nov 5 21:58:55 EST 2008

Issue 235: Install problem finding X11 libs on OSX Leopard

New issue report by hitesh.jasani:
What steps will reproduce the problem?
1. Verify that you have the X11 libs in /usr/X11/lib -- % locate libX11
2. Try to install Haskell X11 package
3. run configure -- % runhaskell Setup.hs configure
4. configure bombs out saying that it couldn't find the X11 libs

What is the expected output? What do you see instead?

Expecting success, instead see an error.

checking for X... no
configure: error: X11 libraries not found, so X11 package cannot be built
See `config.log' for more details.

What version of the product are you using? On what operating system?

Haskell X11 1.4.4, GHC 6.10.1, Mac OSX Leopard 10.5.5

Please provide any additional information below.

For what it's worth, I've documented the various things I tried and what  
finally worked (setting
LDFLAGS) in this blog entry.   

If this error is due to a module from XMonadContrib, please tag this issue  
with 'Component-
Contrib' below.

Issue attributes:
	Status: New
	Owner: ----

You received this message because you are listed in the owner
or CC fields of this issue, or because you starred this issue.
You may adjust your issue notification preferences at:

More information about the xmonad mailing list