[xmonad] xmonad on OLPC laptop?

Nick Cabatoff ncc at cs.mcgill.ca
Sat Jan 19 02:45:31 EST 2008

Hi folks,

I've been using xmonad since 0.3 and loving it.  Thanks to all who've
contributed for their hard work; the WM is so good that you managed to infect
me with the Haskell bug just so I could customize it, though I've yet to
actually write any original code in it.

Anyway, we finally got our OLPC XO-1s up here in Canada this week and now I'm
trying to get xmonad running on it like I've seen in the pictures.  This is on
debian etch, installed via olpc-update debian-big.  After a bit of frustration
with ghc6.6, which has worked well for me on Ubuntu feisty and gutsy, I moved
my sources.list to unstable and upgraded to 6.8.

I had good experiences building xmonad 0.5 and xmobar on gutsy using
cabal-install, so I tried to go that route this time too.  I got all the
dependancies built, but then when it came to the final link stage I ran out of
memory.  Added swap, but then it got very slow once ld crept around the 200MB
mark (there's 237604k available total according to top, excluding swap) and
vmstat showed that the system was spending virtually all of its time waiting.
I suppose I could connect a USB hard disk rather than building off SD card, but
it was easier to abandon cabal-install and go with the packages Joachim
Breitner has announced on this list.

I installed the .deb files from ~nomeata and did apt-get install -f to get the
missing dependancies.  I had to delete some gnome stuff to make it all fit but
that won't be missed.  Everything works like a charm if I just run startx and
put xmonad by itself in my .xinitrc.  Very nice work Joachim.  However, I'd
ideally like to have the same setup as on my desktop, which means xmobar.
There, I have in my .xsession:

    rm -f $PIPE                                                                             
    PATH=${PATH}:/sbin mkfifo -m 600 $PIPE                                                  
    [ -p $PIPE ] || exit                                                                    
    xmobar &                                                                                
    xmonad > $PIPE    

xmobar was easy enough to build too.  When I run startx however, xmobar
launches normally but xmonad quickly dies.  Or that's what I thought at first.
I tried changing the line to

    strace -o /tmp/s -f xmonad > $PIPE    

and the strace output file wasn't created.  So it seems like the shell running
.xinitrc is getting stuck trying to open $PIPE for xmonad's stdout, and never
getting around to launching xmonad.

I thought maybe it might be a JFFS2 thing, so I tried changing $PIPE to use an
ext3 volume, but that didn't help either.  Anyone else have any ideas?

To be honest, I'm not sure I'm really going to be willing to sacrifice any of
my precious screen real estate on this machine to xmobar, but I'd like to give
it a try before dismissing it.

On Jan 06, Don Stewart wrote:
> armin:
> > Hi all,
> > 
> > did anybody get xmonad to run on the OLPC laptops?
> > Could you share instructions how you installed it?
> > 
> > Thanks a lot,
> > -Armin
> > P.S.: Sorry if you get this email twice.
> yes, xmonad runs on the OLPC. see the photo on xmonad.org,
> we don't have instructions, but apparently you just build on a normal
> machine, and then dump the xmonad binary on the laptop.
> _______________________________________________
> xmonad mailing list
> xmonad at haskell.org
> http://www.haskell.org/mailman/listinfo/xmonad

More information about the xmonad mailing list