[xmonad] Strange Thunar CPU idling phenomenon

semdornus semdornus at gmail.com
Wed Feb 20 00:22:02 EST 2008

I'm using XFCE's filemanager Thunar and am witnessing something strange
when using xmonad. I would like to know if this is a problem with
xmonad, or with my system. So if anyone uses Thunar could you please
check if this happens?

I tried this with my own config, but it happens with no config (=default
one) as well.

Steps to reproduce:

1. Start xmonad.
2. Start Thunar.
3. Move Thunar to a different workspace.
4. Observe Thunar's idling CPU state in htop or similar.
   On my PC it is now idling at 3-7%.
5. Switch to workspace where Thunar now is and change Thunar to a
   different directory.
6. Check CPU idling again. It is now 0% as expected.

Strange thing is that just focusing Thunar on the second workspace isn't
enough; you have to change the directory. I have no idea what causes
this strange behavior. I tried other (tiling) window managers and they
all start idling Thunar at 0% as expected.

Anybody have an insight?

More information about the xmonad mailing list