[xmonad] Fedora 10, Gnome and Xmonad

Jan Müller mueller at imt.uni-luebeck.de
Fri Dec 5 08:21:58 EST 2008

(Warning: As pointed out below my knowledge of Haskell, Xmonad and Linux is very limited, so please bear with me)

Short version:
Getting xmonad up and running under Fedora 10 in combination with Gnome is not straightforward. After several hours I found a solution which is posted below. It would be nice if someone would update the Wiki page accordingly.

Longer version:


I hope it's ok to post stuff like this on the mailing list:

During the last two days I had severe problems getting xmonad up and running under a freshly installed Fedora 10. A few minutes ago I was able to solve the problem and now I want to share experiences in the hope that it will be useful for people having the same problem. 

Additionally, it would be really nice if someone would take the following information, put them into a nicer form and then update [1] (I could do this myself but since I'm more a less a complete Linux-, Haskell-, and Xmonad-noob, I think a more experienced person could do a much better job)

So, what went wrong?

First I was looking for precompiled packages for 64bit Fedora 10 but in the end I had to compile everything by myself. After an hour or so I got a file called xmonad in /usr/local/bin/. In order to test it I did a

killall metacity; xmonad &

with the old xmonad.hs from my previous Ubuntu installation. Besides some cryptic warnings (in the console window where I startedxmonad) everything worked fine. (I could not find any occurence of these warnings anywhere, so if someone is interested I can have a second look and post them on the list)

After this the real trouble begun:

Essentially all available tips on how to replace metacity with xmonad (or any other window manager) do _not_ work under Fedora 10!

Some things I tried:
- .gnomerc
- .xinit / .xsession
- the stuff described under "2.2 gnome-session" on [1]
- some stuff mentioned in [2]

While reading [2] I got the impression that this problem is not restricted to xmonad.

After searching some more I stumbled onto the first three paragraphs on [3]. Unfortunately the tips given there are not complete, but after finding [4] I was able to combine both approaches and make it work (at least for me) :)

First step:
create a file called Xmonad.desktop in /usr/share/applications which contains the following:

[Desktop Entry]
# change this path according to your xmonad binary

I copied Metacity.desktop and replaced some lines. I'm sure some of these lines can be removed but since this works for me without any problems I'm not going to put more time in this.

Second step:
Use gconf2 or gconf-edit to set /desktop/gnome/applications/window_manager to "xmonad"

It seems that this key is deprecated (see [3]) but (at least for me) it's the only way to get it work.

Final steps:
Log out, log in, and (hopefully) enjoy xmonad

If someone has an easier/better solution to this problem, please tell me :)

Thanks for all your work on xmonad,

[1] http://www.haskell.org/haskellwiki/Xmonad/Using_xmonad_in_Gnome
[2] http://newsgroups.derkeiler.com/Archive/Uk/uk.comp.os.linux/2008-10/threads.html#00093
[3] http://www.haskell.org/haskellwiki/Talk:Xmonad/Using_xmonad_in_Gnome
[4] http://n2.nabble.com/Is-Gnome-windown-manager-switching-broken-again--td1394329.html

More information about the xmonad mailing list