[Xmonad] Infelicitous name choice in XPrompt.hs clashes with
mailing_list at istitutocolli.org
Wed Sep 19 02:21:09 EDT 2007
On Tue, Sep 18, 2007 at 04:27:57PM -0400, Gwern Branwen wrote:
> Perhaps I've misunderstood something, but isn't the borderPixel
> field specifying the width in pixels? I mean, that's what the
> borderWidth in Config.hs seems to be doing, and the equivalent
> things in StumpWM/Ratpoison also seem to be measuring in pixels.
well, yes, you are right, you specify the width in pixel... but...
actually the type of borderWidth is Dimension and not Pixel. It is
true that both Pixel and Dimension are synonymous of Word32, but they
refer to different things: a color the first, a dimension the
> How else could you describe how wide something'd be? It's not a
> percentage of screen size or using ems as a unit, is it?
If you look at the window's attributes, for instance, you'll see that
bodrerPixel (cWBorderPixel in Haskell) means the color of the window's
border. The same for cWBackPixel.
It is just for conforming to the Xlib convention that I'm asking to
mysleft if borderPixel is the right name. Perhaps David's
promptBorderWidth is better?
Let me know what you think.
More information about the Xmonad