[Xmonad] Infelicitous name choice in XPrompt.hs clashes with
mailing_list at istitutocolli.org
Tue Sep 18 15:05:12 EDT 2007
On Tue, Sep 18, 2007 at 12:37:11PM -0400, Gwern Branwen wrote:
> So I ran into a name-conflict with XPrompt.hs. The issue basically is that a function borderWidth is already defined in Config.hs. Thus, if one attempted to use a prompt configuration different than defaultXPConfig, and one defined it in one's Config.hs where it should be, then the borderWidth field would cause a warning by -Wall, since borderWidth is already a name being used by XMonad at large.
> + , borderPixel :: Dimension -- ^ Border width
the title of this message is definitely correct. But I'm not sure
about the new field name: as far as my English goes, not that far
actually, Pixel, in the Xlib library, refers to colors and depth, not
to dimensions (think about blackPixel). While I think that with need a
better name, can you confirm me that this is the right one?
More information about the Xmonad