[Xmonad] incorrect mouse cursor in some apps

Andrew Sackville-West andrew at swclan.homelinux.org
Fri Oct 26 12:50:52 EDT 2007


I chatted briefly with nomeata yesterday and the consesus was that my
problem is not an app issue but instead something in my system or build
of xmonad. 

the problem: some apps, a blank workspace and the border around
windows all show the default "X" mouse cursor. This shows up in a
variety of apps: gnucash, xpdf, xvidtune*, Xdialog**. There are probably
others, but I haven't gone through the whole list. Other apps work
just fine: urxvt and other terminals show the usual text-insertion
cursor. firefox/iceweasel show an arrow or insertion cursor as
expected and so forth.

I'm not really sure where to go from here in terms of trouble shooting
this, but I wonder if I'm missing some -dev package that supports this
but doesn't cause a configure failure? I don't know

I'm running xmonad 0.4 built from source (not nomeata's .debs) on
up-to-date debian sid. I've installed and tried a couple different
mouse themes just to see if that was the problem and it didn't help. 

* xvidtune is interesting. It shows the "X" cursor everywhere but in
the slide bars. There it shows the <=> cursor.

** Xdialog is interesting too. If I run just Xdialog with no
arguments, it puts up a dialog with usage information. That dialog
shows the insertion cursor when over the text portion of the window
but shows the "X" when over the buttons or border...

Any suggestions about where to look are appreciated.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://www.haskell.org/pipermail/xmonad/attachments/20071026/912ce8e6/attachment.bin

More information about the Xmonad mailing list