[Xmonad] issue building xmonad on OS X 10.4

Vincent Kraeutler vincent at kraeutler.net
Sat Oct 20 06:57:30 EDT 2007

Don, Spencer:

Spencer Janssen wrote:
> On Saturday 20 October 2007 04:32:06 Vincent Kraeutler wrote:
>> Vincent Kraeutler wrote:
>>> Don Stewart wrote:
>>>> Can I just confirm this was fixed by runhaskell Setup.lhs clean in the
>>>> xmonad directory? (And is this bug in ghc's recompilation checker:
>>>>     http://hackage.haskell.org/trac/ghc/ticket/1372
>>>> -- Don
>> I just realize I have misunderstood your question, and I would like to
>> clarify: I don't think the problem was a lack of recompilation of
>> modules in xmonad. Rather, X11-extras failed to export these three
>> required symbols (as I could verify with a bit of nm). So the problem
>> was with X11-extras rather than xmonad.
> These constants were added shortly after the 0.4 release.  In general, you
> should run the darcs version of X11-extras with the darcs version of xmonad.
> Cheers,
> Spencer Janssen

I believe I can now summarize: My build problem was _not_ due to
but rather due to a simple mistake of mine: I used xmonad-0.4 from darcs
while using the non-darcs X11-extras package.

Thank you very much for your help.
Kind regards,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 249 bytes
Desc: OpenPGP digital signature
Url : http://www.haskell.org/pipermail/xmonad/attachments/20071020/a61b19b9/signature.bin

More information about the Xmonad mailing list