[Xmonad] Current darcs version doesn't compile

Don Stewart dons at galois.com
Wed Oct 10 13:05:55 EDT 2007

> On Wed, Oct 10, 2007 at 09:49:44AM -0700, David Benbennick wrote:
> > The current version of xmonad in darcs doesn't compile for me:
> > [6 of 6] Compiling Main             ( Main.hs,
> > dist/build/xmonad/xmonad-tmp/Main.o )
> > 
> > Main.hs:258:7: Not in scope: data constructor `PropertyEvent'
> > 
> > Main.hs:258:42: Not in scope: `ev_atom'
> ...
> > 
> > Maybe a dependency is missing from the configure step?  Any ideas?  I
> > was able to compile from darcs two weeks ago.
> to run the darcs version of Xmonad you need the darcs version of
> X11-extras.
> Andrea
> ps: there should be a clear note in the README. This is also a V(ery)FAQ... ;)

Quoth the README:

    Notes for using the darcs version

        If you're building the darcs version of xmonad, be sure to also
        use the darcs version of X11-extras, which is developed concurrently
        with xmonad.

            darcs get http://code.haskell.org/X11-extras

        Not using X11-extras from darcs, is the most common reason for the
        darcs version of xmonad to fail to build.

Hopefully, this, along with Cabal checking, will help out the darcs users avoiding this problem

More information about the Xmonad mailing list