[Xmonad] Problem while building Xmonad

Don Stewart dons at galois.com
Fri Nov 2 01:28:32 EDT 2007

> Hello everybody,
> I was trying to build xmonad and stumbled upon a problem.
> I have already installed X11-1.3.0 and X11-extras-0.4. It seems
> that they both expose a module 'Graphics.X11.Xlib.Extras'.
> As a result of this, while trying to build xmonad, I get:
> ----------------------------------------------------------------
> santanu at sc214:~/Desktop/xmonad/xmonad-0.4$ runhaskell Setup.lhs build
> Preprocessing executables for xmonad-0.4...
> Building xmonad-0.4...
> XMonad.hs:38:7:
>     Could not find module `Graphics.X11.Xlib.Extras':
>       it was found in multiple packages: X11-extras-0.4 X11-1.3.0
> santanu at sc214:~/Desktop/xmonad/xmonad-0.4$ ghc-pkg list
> /usr/lib/ghc-6.6/package.conf:
>     Cabal-1.1.3, Cabal-1.1.6, X11-1.3.0, X11-extras-0.4, base-2.0,
>     filepath-1.0, (ghc-6.6), haskell98-1.0, mtl-1.0, parsec-2.0,
>     readline-1.0, regex-base-0.71, regex-compat-0.71, regex-posix-0.71,
>     rts-1.0, stm-2.0, template-haskell-2.0, unix-1.0, unix-2.0
> -----------------------------------------------------------------
> How do I solve this problem? (I am completely new to haskell. So
> I apologize in advance if this is too trivial a question).
> By the way, I also tried to unregister X11-1.3.0 and installed X1-1.2.3
> (since it does not seem to expose the module in question) and tried
> again. But that did not work either.
> Thanks in advance for your help.
> Regards,
> Santanu Chatterjee

Yes, you've run across an inadvertant problem with the recent release of
X11-1.3.0. To build xmonad 0.4, you should use only X11 1.2.3, and
X11-extras. So you should unregister X11 1.3.0, install X11 1.2.3, and
X11-extras, and then be sure to clean your xmonad build:

    runhaskell Setup.lhs clean

before rebuliding, which should solve any remaining build problem.

Spencer, perhaps we should do a point release of xmonad -- or just get
0.5 out sooner?

-- Don

More information about the Xmonad mailing list