[web-devel] [Yesod] Abstracting permissions with Yesod

Felipe Almeida Lessa felipe.lessa at gmail.com
Fri Feb 3 18:21:47 CET 2012

On Fri, Feb 3, 2012 at 3:11 PM, Bryan Richter <bryan.richter at gmail.com> wrote:
> Yep, that's pretty much it. And given how much longer you've used your
> system than I have, I'm prepared to be okay with just using
> 'Permission'. :)

I don't have any strong opinions either way, Credentials may be a
better name.  (Also, I'm not a native English speaker.)

> credentialsRequiredFor NewPersonR _    = LoggedIn
> credentialsRequiredFor DefaultGroupR _ = InSomeGroup
> credentialsRequiredFor (GroupR gid)   _  = InGroup gid
> Can you maybe suggest better names for Permissions I could use in this scenario?

These are good enough for me.  Use whatever name that floats your boat =).



More information about the web-devel mailing list