[web-devel] yesod build failure on Mac

Sven Koschnicke s.koschnicke at gfxpro.com
Thu May 12 09:18:38 CEST 2011

> On Thu, May 12, 2011 at 9:02 AM, Mark Wotton <mwotton at gmail.com> wrote:
> cabal install yesod fails because certificate-0.9.0 won't build on Mac.

On my mac, installing the certificate package as yesod dependency worked:

darkunicorn at PALANTHAS ~> uname -a
Darwin palanthas 10.7.0 Darwin Kernel Version 10.7.0: Sat Jan 29 15:17:16 PST 2011; root:xnu-1504.9.37~1/RELEASE_I386 i386
darkunicorn at PALANTHAS ~> cabal list certificate
* certificate
    Synopsis: Certificates and Key Reader/Writer
    Default available version: 0.8.1
    Installed versions: 0.7.0
    Homepage: http://github.com/vincenthz/hs-certificate
    License:  BSD3

But when I now try to install the newer version 0.8.1 I get the same error. Try install version 0.7.0, works fine with yesod here.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.haskell.org/pipermail/web-devel/attachments/20110512/cad0b045/attachment.htm>

More information about the web-devel mailing list