[web-devel] Problem installing yesod-form 0.1.0

Sven Koschnicke s.koschnicke at gfxpro.com
Thu Apr 28 06:52:44 CEST 2011


today I tried to update to yesod 0.8, but cabal install fails at building yesod-form 0.1.0:

[3 of 8] Compiling Yesod.Form.Jquery ( Yesod/Form/Jquery.hs, dist/build/Yesod/Form/Jquery.o )
[4 of 8] Compiling Yesod.Form.Nic   ( Yesod/Form/Nic.hs, dist/build/Yesod/Form/Nic.o )
[5 of 8] Compiling Yesod.Form.Fields ( Yesod/Form/Fields.hs, dist/build/Yesod/Form/Fields.o )
[6 of 8] Compiling Yesod.Form.Class ( Yesod/Form/Class.hs, dist/build/Yesod/Form/Class.o )
[7 of 8] Compiling Yesod.Form       ( Yesod/Form.hs, dist/build/Yesod/Form.o )
[8 of 8] Compiling Yesod.Helpers.Crud ( Yesod/Helpers/Crud.hs, dist/build/Yesod/Helpers/Crud.o )

Yesod/Helpers/Crud.hs:63:25: Not in scope: `toSinglePiece'

Yesod/Helpers/Crud.hs:97:39: Not in scope: `fromSinglePiece'

Yesod/Helpers/Crud.hs:109:39: Not in scope: `fromSinglePiece'

Yesod/Helpers/Crud.hs:120:39: Not in scope: `fromSinglePiece'

Yesod/Helpers/Crud.hs:144:39: Not in scope: `fromSinglePiece'

Yesod/Helpers/Crud.hs:166:42: Not in scope: `toSinglePiece'

Yesod/Helpers/Crud.hs:172:25: Not in scope: `toSinglePiece'


cabal: Error: some packages failed to install:
yesod-0.8.0 depends on yesod-form-0.1.0 which failed to install.
yesod-auth-0.4.0 depends on yesod-form-0.1.0 which failed to install.
yesod-form-0.1.0 failed during the building phase. The exception was:
ExitFailure 1

I already tried to remove .cabal and .ghc, but a fresh install fails with the same error. I have ghc 7.0.2 running on macos 10.7
> cabal --version
cabal-install version 0.10.2
using version of the Cabal library 

  Sven Koschnicke

More information about the web-devel mailing list