[web-devel] base-unicode-symbols not compiling

Michael Snoyman michael at snoyman.com
Thu Apr 21 06:08:27 CEST 2011

Interesting, thanks for the pointer. I tried compiling, and
sure enough it worked. However, breaks. I suppose I can add an
explicit == to the pool package, but that seems like a
suboptimal solution.


On Thu, Apr 21, 2011 at 7:05 AM, Chris Smith <cdsmith at gmail.com> wrote:
> I know in one application of mine, I had to add an explicit dependency for
> version in order to get it to compile on GHC 6.12.3.  That might be
> worth a shot.  I'd heard that there was a fix in a later version for the
> issue I had, but if you're still getting failures, perhaps adding a version
> bound would help.
> Then again, this may be related to people not running cabal update since the
> fix was released... so maybe the first answer is to suggest a cabal update.
> On Apr 20, 2011 10:00 PM, "Michael Snoyman" <michael at snoyman.com> wrote:
>> Hi Bas,
>> I'm getting sporadic bug reports about base-unicode-symbols not
>> compiling, which is preventing Yesod from compiling. I actually got
>> the same error on GHC 6.12.1, and hacked around it by manually
>> modifying the file to avoid the problematic CPP code. You can see a
>> report in a Yesod book comment[1].
>> I think I remember you saying this is a problem with the CPP in GHC
>> 6.12.1. Do you know if there's any workaround?
>> Thanks,
>> Michael
>> [1] http://www.yesodweb.com/book/migrate7to8#iy1
>> _______________________________________________
>> web-devel mailing list
>> web-devel at haskell.org
>> http://www.haskell.org/mailman/listinfo/web-devel

More information about the web-devel mailing list