[web-devel] Web.Encodings + Hack - Not sure what I'm doing wrong.

Michael Snoyman michael at snoyman.com
Tue May 18 01:48:57 EDT 2010

On Tue, May 18, 2010 at 8:16 AM, Clint Moore <cmoore at wamboli.com> wrote:

> The project that I'm working on requires user image galleries.  The
> idea is to allow them to upload images via a form, do some rudimentary
> processing on the uploaded data and then send it directly to Amazon's
> S3 service.  The problem that I'm running in to is that I can't seem
> to get the binary data from the post request correctly.  When written
> out to disk with withBinaryFile (hopefully thereby bypassing the new
> encoding pitfalls in ghc 6.12.x), file(1) says it's 'data'.  This
> seems to be happening if I push it to a new object on S3 as well.
> I'm secretly hoping I'm doing something obviously wrong here.
> The code in question is at http://gist.github.com/404636 .  Hopefully
> it's obvious that it's way more frantic what-the-hell-is-going-on-here
> code than some crackpot's idea of production ready code :)
> Thanks, web-devel!


Firstly, would it be possible to modify your gist so that it's runnable on
it's own? It's hard to debug what I can't see first hand.

Secondly, I'm not certain I understand what you're saying the problem is.
You mean that the file contents are simply "data"?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.haskell.org/pipermail/web-devel/attachments/20100518/090b9d56/attachment.html

More information about the web-devel mailing list