[reactive] reactive 0.10.5 Install problem

Tom Poliquin poliquin at softcomp.com
Wed Feb 18 02:10:38 EST 2009

I hope this is the correct place to ask this.

I've been playing with Haskell for a few months (I'm a long time
imperative programmer with a couple years of Scheme)
and *still* feel like a complete newbie. It seems like there's
always something new to wrap my head around (one
could argue this makes it fun .. ?). Java never twisted
my brain :-)

I eventually want to write a simulator for an alternate computer
architecture in Haskell. . I played around with arrows and managed to 
understand the Arrow SF versions fibonacci and factorial and get them

It appears reactive may be more appropriate.

I was running ghc 6.8.3 and upgraded to 6.10.1 as it seemed
that it would be more 'reactive' friendly.
Platform is  x86_64 GNU/Linux.
All seemed to go smoothly but I can't install reactive 0.10.5.

Details of the problem are given below.

Any help greatly appreciated,


Error message  ............

[poliquin at curunir reactive-0.10.5]$ runghc Setup configure --user
Configuring reactive-0.10.5...
Warning: This package indirectly depends on multiple versions of the same
package. This is highly likely to cause a compile failure.
package reactive-0.10.5 requires QuickCheck-
package checkers-0.1.3 requires QuickCheck-
package Stream-0.3.1 requires QuickCheck-

Misc Info ...........

[poliquin at curunir ~]$ ghc --version
The Glorious Glasgow Haskell Compilation System, version 6.10.1

[poliquin at curunir ~]$ ghc-pkg list
    Cabal-, HUnit-, QuickCheck-, array-,
    base-, base-, bytestring-, containers-,
    directory-, (dph-base-0.3), (dph-par-0.3),
    (dph-prim-interface-0.3), (dph-prim-par-0.3), (dph-prim-seq-0.3),
    (dph-seq-0.3), editline-, filepath-, (ghc-6.10.1),
    ghc-prim-, haddock-2.3.0, haskell-src-,
    haskell98-, hpc-, html-, integer-,
    mtl-, network-, old-locale-, old-time-,
    packedstring-, parallel-, parsec-,
    pretty-, process-, random-,
    regex-base-, regex-compat-, regex-posix-,
    rts-1.0, stm-, syb-, template-haskell-,
    time-, unix-, xhtml-3000.2.0.1
    FTGL-1.1, GLUT-, HGL-, MemoTrie-0.4.3,
    OpenGL-, QuickCheck-, Stream-0.3.1,
    TypeCompose-0.6.4, X11-1.4.5, arrows-0.4.1, category-extras-0.53.5,
    checkers-0.1.3, lazysmallcheck-0.3, unamb-0.1.9, vector-space-0.5.3

More information about the Reactive mailing list