<div dir="ltr">I, for one, could get behind just taking ifM, whenM, unlessM for these operations, proper naming conventions aside.<div><br></div><div>They've been independently reinvented in 60+ packages with these exact names.</div>
<div><br></div><div>If we do this, over time we'll save another 60+ packages the trouble of doing the same thing.</div><div><br></div><div>-Edward</div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Mon, Apr 21, 2014 at 11:38 AM, Mario Pastorelli <span dir="ltr"><<a href="mailto:pastorelli.mario@gmail.com" target="_blank">pastorelli.mario@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div text="#000000" bgcolor="#FFFFFF"><div class="">
<div>On 04/21/2014 02:55 PM, Brandon Allbery
wrote:<br>
</div>
<blockquote type="cite">
<div dir="ltr">
<div class="gmail_extra">
<div class="gmail_quote">On Mon, Apr 21, 2014 at 5:35 AM,
Mario Pastorelli <span dir="ltr"><<a href="mailto:pastorelli.mario@gmail.com" target="_blank">pastorelli.mario@gmail.com</a>></span>
wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div>On 04/21/2014 10:41 AM, Simon Hengel wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
A quick heuristic grep over all Hackage packages
results in quite a bit<br>
of packages containing the ifM/whenM/unlessM:<br>
</blockquote>
But that kind of shows that the "expected" names for
those functions are<br>
ifM/whenM/unlessM. I would ask the question:<br>
<br>
Are there any other useful combinators that would
be named<br>
ifM/whenM/unlessM under the current naming
convention?<br>
<br>
If no, then I'm not entirely convinced that we should
decide against<br>
what seems to be common intuition here.<br>
</blockquote>
<br>
</div>
Breaking API consistency because a lot of people are
already doing it doesn't feel right. If they </blockquote>
<div><br>
</div>
<div>The API is there to serve its users, not really to
dictate to them. If the common convention is counter to
the API structure, perhaps it is the API that should
change.</div>
<br>
</div>
</div>
</div>
</blockquote>
<br></div>
I agree with you but I'm not the developer of this API. Considering
how important is Control.Monad for Haskell I think it's important to
pick the right name for new functions.<br>
</div>
<br>_______________________________________________<br>
Libraries mailing list<br>
<a href="mailto:Libraries@haskell.org">Libraries@haskell.org</a><br>
<a href="http://www.haskell.org/mailman/listinfo/libraries" target="_blank">http://www.haskell.org/mailman/listinfo/libraries</a><br>
<br></blockquote></div><br></div>