It wouldn't have to be a change. We could add these new synonyms. I'm personally happy with first & second for use with functions & other Arrow types. My main suggestion is that if we want new names for memorability, then let's add them for the general meanings rather than the specialized ones.
<br><br><div><span class="gmail_quote">On 10/15/07, <b class="gmail_sendername">Bertram Felgenhauer</b> <<a href="mailto:firstname.lastname@example.org">email@example.com</a>> wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<br>Changing the names of 'first' and 'second' in Control.Arrow is a bad<br>idea, I think. It'll break a lot of packages.</blockquote><div><br>[...] <br></div><br></div><br>