Bikeshedding the cstringLength name?

Viktor Dukhovni ietf-dane at
Tue Jan 26 04:59:18 UTC 2021

On Mon, Jan 25, 2021 at 08:09:01PM -0800, Edward Kmett wrote:

> [...Sound argument for consistency of style...]
> Names matching primitives modulo a hash is pretty universal as well.

Just on this one point, the reason I contemplated something different
than `cstringLength` and was led to `bytestring` as a possible model,
was because the primop is differs subtly from the new lifted function
by being "pure" (and is then only safe for compiled-in constants).

Since the proposed lifted variant changes not only the levity but also
the purity, I thought it worth asking whether that could be a source of
confusion, with some users accidentally misusing the primop, expecting
only a difference in levity.  But likely I let my imagination run wild.

The proposed name is fine.


More information about the Libraries mailing list