Add NonEmptyMap and NonEmptySet to containers

Ruben Astudillo ruben.astud at
Fri Sep 20 01:56:26 UTC 2019

On 19-09-19 22:17, Alexandre Esteves wrote:
> I do like the sound of `instance Foldable1 Set1` more than I do
> `instance NonEmptyFoldable NonEmptySet`
> <>

I prefer it too, I just wish (future) documentation included a little
explanation on why the suffix 1 was put.

-- Ruben
-- PGP: 4EE9 28F7 932E F4AD

More information about the Libraries mailing list