Proposal: give a field name to Data.Ord.Down

Theodore Lief Gannon tanuki at gmail.com
Fri May 3 18:39:10 UTC 2019


I just added `Down` to the RIO prelude, and the absence of a deconstructor
was my #1 concern about doing so. It invites another package to provide an
alternative, and we avoid including things with actively competing
implementations. I'd much rather see this handled in `base`.

(I'd rather have it named `unDown`, so as not to steal the name `getDown`
from the heroes who will pair it with `getFunky`. But that's a lesser
concern.)

On Thu, May 2, 2019 at 8:13 PM davean <davean at xkcd.com> wrote:

> I have needed this many times.
>
> On Thu, May 2, 2019 at 10:56 PM Fumiaki Kinoshita <fumiexcel at gmail.com>
> wrote:
>
>> It's awkward to write a lambda to unwrap this kind of wrappers. I propose
>>
>> newtype Down a = Down { getDown :: a }
>>
>> with the Show/Read instances as if they didn't have named fields.
>>
>> The same goes for Control.Arrow.ArrowMonad, although I'm not sure about
>> its usefulness...
>> _______________________________________________
>> Libraries mailing list
>> Libraries at haskell.org
>> http://mail.haskell.org/cgi-bin/mailman/listinfo/libraries
>>
> _______________________________________________
> Libraries mailing list
> Libraries at haskell.org
> http://mail.haskell.org/cgi-bin/mailman/listinfo/libraries
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.haskell.org/pipermail/libraries/attachments/20190503/dc83a824/attachment.html>


More information about the Libraries mailing list