generalize type of Data.Set.unions from List to Foldable

Joachim Breitner mail at
Sun Feb 4 20:09:55 UTC 2018


Am Samstag, den 03.02.2018, 20:44 -0500 schrieb David Feuer:
> It is fold, although fold is not so great for lists in this context. It's also foldl' union Set.empty, which is better for lists, and probably also for balanced trees. I initially thought that we should surely generalize, but now another alternative comes to mind: remove. As a containers maintainer, I believe we should either:
> 1. Generalize as proposed, or
> 2. Deprecate and remove.
> I'm currently somewhat in favor of the second option.

please don’t remove!

…is first reaction. Now I just have to rationalize my gut feeling…

I like the readability of it in code, it is more descriptive. It is an
important analogue to unionsWith. If we remove unions because of fold,
shouldn’t we also remove union because of (<>)?


Joachim Breitner
  mail at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the Libraries mailing list