Proposal: add ordNub somewhere in containers

Henning Thielemann lemming at
Thu Oct 19 07:50:47 UTC 2017

On Wed, 18 Oct 2017, Gershom B wrote:

> Vis a vis NonEmpty, base provides a partial `fromList`, much as I 
> dislike it. Hence, the proper "roll your own" is `fromList . ordNub . 
> toList`.

My idea of NonEmpty is to prove totality by implementation. I'd prefer a 
custom obviously total implementation of NonEmpty.ordNub.

More information about the Libraries mailing list