Discussion: Add total indexing function to Data.Sequence

David Feuer david.feuer at gmail.com
Sun May 29 22:52:53 UTC 2016

I'm tempted to go with `lookup`, to match Data.IntMap.

On Sun, May 29, 2016 at 6:35 PM, Francesco Ariis <fa-ml at ariis.it> wrote:
> On Sun, May 29, 2016 at 06:28:25PM -0400, David Feuer wrote:
>> I don't like that bikeshed color much either. Go ahead and suggest
>> something else.
> safeIndex? totalIndex? Best solution would be to rename index to
> unsafeIndex and your proposed function to index, but it's obviously
> not practicable.
> _______________________________________________
> Libraries mailing list
> Libraries at haskell.org
> http://mail.haskell.org/cgi-bin/mailman/listinfo/libraries

More information about the Libraries mailing list