Names for general merge tactics in Data.Map

Henning Thielemann lemming at
Sat Aug 20 07:40:02 UTC 2016

On Thu, 18 Aug 2016, David Feuer wrote:

> I realized that it would probably be helpful to put up the actual
> documentation for the proposed functions. This can be found at

The description of 'generalMerge' mentions diffPreserve, diffDrop, 
diffMapWithKey, but they are not shown in the Haddock page.

Since there are pretty many functions around 'generalMerge' I would keep 
that stuff in one module and also rename 'generalMerge' to 'merge' because 
the new module provides enough distinction from Data.Map.mergeWithKey.

Your solution looks pretty elegant to me but for a definitive judgement I 
would like to test it in real applications first. I remember some actual 
and potential uses of 'mergeWithKey' in my code. [1][2][3] It is 
unfortunate that depending on a newer version of containers also forces me 
to depend on new GHC versions. Could you provide the Merge modules in a 
separate package, say containers-merge or containers-compat? Would it be 
possible to implement the Merge modules using the existing mergeWithKey 


More information about the Libraries mailing list