Monad of no `return` Proposal (MRP): Moving `return` out of `Monad`

Christopher Allen cma at
Sat Sep 26 00:29:16 UTC 2015

Box is good but overlaps with unboxed/boxed types. Wrap is good.

On Fri, Sep 25, 2015 at 7:27 PM, Imants Cekusins <imantc at> wrote:

>  > wish it wasn't named pure
> How about "wrap" or "box" (as in box-unbox)?

Chris Allen
Currently working on
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Libraries mailing list