Cabal cannot resolve dependencies for my Yesod website

Philip White philip at
Wed Jun 24 05:03:35 UTC 2015

Thanks for the quick reply. With your arguments, it worked! But that cabal invocation (without the add'l args) is set by CircleCI.

From my brief research, both of the arguments you suggest result in more successful dependency resolutions, at the potential expense of time. Sounds like a good case for CircleCI to start passing these arguments to all Haskell projects by default. I'll contact them about this.

> On Jun 23, 2015, at 9:47 PM, Michael Snoyman <michael at> wrote:
> I answered on Stack Overflow, but copying here:
> This looks like a typical cabal dependency solver shortcoming. Can you try running again with `--max-backjumps=-1 --reorder-goals`?
> On Wed, Jun 24, 2015 at 7:07 AM Philip White <philip at <mailto:philip at>> wrote:
> Hello, all,
> I am trying to make the next big thing with Yesod -- but for now, just a Hello World website. After getting it running locally, I tried to integrate it with Circle CI, which has support for cabal-based Haskell projects.
> Circle CI runs the following commands:
> cabal sandbox init
> cabal install --upgrade-dependencies --constraint="template-haskell installed" --dependencies-only --enable-tests
> With this invocation, cabal cannot resolve dependencies no matter how I change the cabal config. If, however, I run just `cabal install`, everything works.
> This cabal failure occurs both on a CircleCI host and my laptop exactly the same way, so I know it's not my environment.
> I wrote a StackOverflow question with more details: <>
> The github repo, for ease of reproducing the problem: <>
> I hope that someone on the list is able to help. Thanks.
> --
> Philip
> _______________________________________________
> Libraries mailing list
> Libraries at <mailto:Libraries at>
> <>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Libraries mailing list