Proposal to deprecate and then drop fromJust

Henning Thielemann lemming at
Tue Feb 24 19:59:09 UTC 2015

On Tue, 24 Feb 2015, Greg Weber wrote:

> Michael and I came up with an approach of using a convention in mono-traversable where any partial function
> has the postfix `Ex`, which stands for (throws a pure) Exception. So there is a `headEx` and `tailEx`
> function. This is a very light-weight solution although it is certainly easy for someone to ignore a new
> naming convention.

The only problem is, that "error" is not an exception, but, well, an 
error. Why not naming partial functions with something that reminds on 

More information about the Libraries mailing list