Proposal unix. Change to `IO (Maybe String)`: getLoginName, getUserEntry* and getGroupEntry*

Brandon Allbery allbery.b at
Fri Sep 26 17:52:48 UTC 2014

On Fri, Sep 26, 2014 at 1:33 PM, Greg Weber <greg at> wrote:

> Agreed with Johan. If there are meaningful error messages that get
> produced, Either is better than Maybe.

"Meaningful" is open to question; what you get back is a NULL pointer amd
an errno, both of which can be annoyingly non-specific.

brandon s allbery kf8nh                               sine nomine associates
allbery.b at                                  ballbery at
unix, openafs, kerberos, infrastructure, xmonad
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Libraries mailing list