Error installing gtk3

Axel Simon Axel.Simon at
Mon May 12 14:36:52 UTC 2014

Hi Francesco,

it seems that you're running a different Gtk version than the developers.

You can safely add a castPtr around the mentioned function calls (toWindow parent) that appear on the lines mentioned in the error message, i.e. Graphics/UI/Gtk/Printing/PrintOperation.chs:409 and others.

If that works, please submit a patch!


On May 12, 2014, at 3:02 PM, Francesco Ariis <fa-ml at> wrote:

> Hello everyone,
>    I am trying to install gtk3 on Debian Wheezy (i386), without much success
> (see attached file for detailed error). I tried running |cabal update|,
> deleting 
> ~/.ghc/<environment>/package.conf.d/glib*
> ~/.ghc/<environment>/package.conf.d/gtk*
> ~/.ghc/<environment>/package.conf.d/webkit*
> ~/.cabal/bin/gtk*
> ~/.cabal/packages/*
> ~/.cabal/packages/*
> ~/.cabal/packages/*
> and then recompiling, but I am still stuck with the same error. Any idea on
> where to look / what to do to fix this?
> Thanks
> -F
> <gtk-err.txt>_______________________________________________
> Libraries mailing list
> Libraries at

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 163 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <>

More information about the Libraries mailing list