transformers 0.4: change in accessor function exports?

Nicolas Trangez nicolas at
Wed May 7 11:53:25 UTC 2014

On Wed, 2014-05-07 at 14:43 +0300, Michael Snoyman wrote:
> Perhaps the latter should be considered a better approach, since it's
> more
> resilient to changes in datatypes.

And (IMHO) it's more in line with expectations. Using `Name(..)` makes
sense when the `..` are constructors or 'true' record field names,
whilst `runReader` sounds more like an ordinary function (no matter what
its actual implementation is).


More information about the Libraries mailing list