Who remembers HP 2013.4.0.0...?

Tim C. Schroeder tim at blitzcode.net
Sun Jan 5 07:35:41 UTC 2014

Thanks for the clarifications! I just saw a number of 7.6.3 + 10.9 reports about linker issues and such popping up in the last few months and remember some work being done to backport a couple of fixes for a 7.6.4 release. If all will be fine with standard Apple Cmd Line Tools, that's great.

I don't think the 10.6 64bit issue is a HP issue in any way. I also tied building my own GHC from source, it did nothing to resolve that crash. I only think it's problematic that the HP download page has been listing 10.6 + XCode 4.1 + GHC 64bit as a working combination when that stopped being the case quite some time ago. It does not seem like that bug will get fixed, so I was just suggesting to update the download page to recommend only the 32bit GHC for 10.6 users.


On Jan 5, 2014, at 1:08 AM, Mark Lentczner wrote:

> The first bug is very hard to decipher how what that user is experiencing may or may not apply to how HP on a stock 10.9/Xcode 5 system will work. In particular that user is using homebrew and a homebrew installed gcc. As one side effect of homebrew is a whole new/different set of libs (for example, there is a well known issue with homebrew and iconv, and I've seen reports in other contexts than Haskell).
> The second two bugs are what they are. I'm don't see how we could do anything different in the packaging of HP to fix them... other than perhaps build GHC from scratch on my machine (rather than Ian's) - but still not sure that will fix the second one.
> - Mark

More information about the Libraries mailing list