Proposal: improve the Data.Tree API

Milan Straka fox at
Fri Feb 28 17:54:23 UTC 2014

Hi Daniel,

> -----Original message-----
> From: Daniel Trstenjak <daniel.trstenjak at>
> Sent: 28 Feb 2014, 15:22
> > But maybe it would be better to have lookupTreeBy instead of findTree --
> > when you see lookupTree and lookupTreeBy, it is quite obvious how they
> > differ. If I saw lookupTree and findTree, I would have to see the docs
> > to find the difference.
> Why then not going with the shorter 'findTree' and 'findTreeBy'?

we are using mostly lookup in containers. Also lookup would be more
consistent with Data.List.lookup (versus Data.List.find).


More information about the Libraries mailing list