Proposal: add new Data.Bits.Bits(bitZero) method

Henning Thielemann schlepptop at
Mon Feb 24 09:47:47 UTC 2014

Am 22.02.2014 15:56, schrieb Carter Schonwald:

> Zero is a big bit of name space.  Id favor zerobits over zero.

... only if you plan to add another "zero" thing to the Data.Bits 
module. Conflicts with other modules must be resolved with importing 
mechanisms, but not by finding names that are different from all other 
identifiers in all other modules in all other packages. It just makes no 
sense to have a nice module system, but use it like the #include 
directive of the C preprocessor and eventually maybe complain about the 
deficiencies of the current module system.

More information about the Libraries mailing list