cabal and extra-libs

fa-ml fa-ml at
Wed Feb 12 07:33:14 UTC 2014

Hello list,

    recently I am having trouble installing a package (hbro,
more info here [1]).
Today I decided to remove every 0mq installed (even system ones)
and run another installation to see what went wrong.
So I downloaded zmq3, reinstalled it, tried to run

    cabal install hnro

which lead to

    Loading package zeromq3-haskell-0.5.1 ... <command line>:
    can't load .so/.DLL for: ( cannot open
    shared object file: No such file or directory)
    cabal: Error: some packages failed to install:

After locating, I typed

    cabal install hbro --extra-lib-dirs=/home/user/media/vcs/zeromq-3.2.4/src/.libs/

This unfortunately was greeted with the same error, which makes me
question wheter I am invoking cabal with the right parameters/wheter
cabal actually looks inside that directory.

Cabal version:

        cabal-install version 0.14.0
        using version 1.14.0 of the Cabal library
        # I use debian/wheezy

Am I incorrectly calling cabal or is this a bug?


More information about the Libraries mailing list