Strange errors trying to install terminfo

Sean McAfee eefacm at
Mon Dec 22 01:15:56 UTC 2014


I hope my question is appropriate here; I couldn't find an obviously
better forum for what is apparently a cabal issue in a fair amount of

I've been trying to install the terminfo package on my Ubuntu system
like so:

> ~$ cabal install terminfo
> Resolving dependencies...
> Configuring terminfo-

At this point, the command hangs, and I notice my mouse cursor has
transformed into a crosshair image for some reason.  I can't click on
anything normally, but after several clicks around the screen, the
command resumes:

> /home/mcafee/node-v0.10.31/configure: line 10: syntax error near unexpected token `('
> /home/mcafee/node-v0.10.31/configure: line 10: `CC = os.environ.get('CC', 'cc')'
> Failed to install terminfo-
> cabal: Error: some packages failed to install:
> terminfo- failed during the configure step. The exception was:
> ExitFailure 2

I executed this command from within an Emacs shell buffer.  I tried
again from an xterm window and got the same result.  I tried yet again
from a textual virtual terminal, and the only difference was that this
line was printed several times after the "Configuring" line:

> import.im6: unable to open X server `' @ error/import.c/ImportImageCommand/368.

Any help resolving this issue would be most welcome.

More information about the Libraries mailing list